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Mestrado em Engenharia GeoEspacial 

Mestrado Sistemas de Informação Geográfica – TA 

ArcGis 10.7.1 
CookBook 

Setembro 2019 

 

Nota: 

Para evitar problemas no transporte dos ficheiros do projecto deverá activar-se a opção 

“store relative path names” 

Document properties>  Data source options> store relative ..” 

 

Dados 

 Cartografia digital do campus da FCUL  

 

nome descrição formato 

Arvore  SHP 

Canteiros  SHP 

Estradas  SHP 

Ciclovias  SHP 

Passeios  SHP 

Parque_estacionamento  SHP 

C1_piso1 Salas do piso 1 do C1 SHP 

C8_piso1 Salas do piso 1 do C1 SHP 

C8_piso2 Salas do piso 1 do C1 SHP 

C8_piso3 Salas do piso 1 do C1 SHP 

Blocos Limite dos edifícios SHP 
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1.MODELAÇÃO DE UMA GEODATABASE 

 

1.1 Criar a Geodatabase 

 

No ArcCatalog 

File> Connect Folder > (escolher um directório para alojar a geodatabase) 

New > File Geodatabase > fcul-2016.gdb 

 

1.2 Criar Domínios 

Criar domínios para limitar valores de variáveis (ver exercício 3 do geodatabase tutorial).  

 

Nas propriedades da Geodatabase podemos criar domínios. Podemos criar dois 

domínios do tipo texto “NomeFuncionario” no qual são inseridos os nomes dos docentes 

e não docentes, “NumeroSala” no qual inserimos os números de sala (tem de ser do tipo 

texto por haver salas com letras). Podemos criar um segundo tipo de domínio no qual 

limitamos o numero de aluno pelo range: 10000 a 60000. Neste caso o atributo é do tipo 

“long int”. 

  

  
 

Ao criar a tabela “docentes” na caixa “field proprieties” selecionamos no “Domain” 

“NomeFuncionario” ou ao criar a entidade “sala” limitamos ao domínio “NumeroSala”. 
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1.3 Criar uma Feature Dataset (Superclasse) 

 

New > Feature Dataset > Edificado 

 

 
 

 

1.4 Criar uma Feature Class (Entidade Geográfica) 

 

New > Feature Class > “Sala_generica” com atributo “numero”. No domínio especificar 

“NumeroSala” previamente criado.  

 

 
 

Campos: numero (long int), edificio (text), piso (short int), designação (text)  

Sala_aula (numero(long int), lugares (short int), datashow (text), laboratorio(text), 

computadores (short int)) 
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2. IMPORTAÇÃO DE FICHEIROS em formato shapeFile 

 

A forma mais correcta de importar dados para o ArcGIS consiste na construção da 

geodatabase completa, com todas as suas FeatureDataSets,  FeatureClasses e Tabelas, 

e posteriormente usar o comando “LOAD” para importar os dados (tudo em ambiente 

ArcCatalog) 

 

> Sobre a entidade com o botão direito selecionar “Load” 

> Load Data > Input data > selecionar todas as entidades com salas (C1_piso1, 

C8_piso1, C8_piso2, C8_piso3) 

 :: Associar “id_sala” ao atributo “numeroSala” 

> para cada uma das entidades carregadas atualizar o atributo piso e edifício. 

 :: Preencher o atributo “piso” com > open atribute table > piso (field calculator) 

> Apagar as que não são salas de aula 

 

Criar todas as entidades do diagrama UML e carregar com os dados disponibilizados. 

Para visualizar os diversos pisos: 

 Proprieties > Definition Query > Query builder > escolher o piso ou edifício que 

se quer ver.  
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3. Criar topologia (na feature dataset) 

 

 

New Topology : “sala_topology” 

Select the feature classes : sala_generica + edificio  

Add Rule : Must not overlap 

Would you like to validate? Yes 

 

  

 

 

Edição da Topologia em ArcMap 

 

 Editor > More Editing Tools > Topology 

 Fix Topology Error tool (fazer merge dos poligonos) 

 Experimentar: o Merge e Subtract 

 Eliminar todos os polígonos que ficam fora do perímetro. 

 

Criar a tolopologia relativa aos edifícios e salas. 

Usar a regra : Sala “Must be covered by feature class of ..” edifício. 

Os dois problemas podem ser classificados como “exception” 

 

Problema: salas de diferentes pisos são sobrepostas. 
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4. Criar Tabelas 

 
Na geodatabase criar uma tabela 

 New > Table > “docentes” 

Definir os atributos: Nome (string), Telefone (short int), N. Gabinete (Long int, domínio 

NumeroSala), departamento (string), telefone (short int), email (string), área_cientifica, 

.. 

 

Em “Field Propriety” definir o domínio. 

 

4.1 importar dados para tabelas (importação de ficheiro XLS) 
 

Na tabela criada fazer  

 Load > Load Data > Seleccionar a tabela “Espaços.xls” 

 Fazer query para selecionar o edificio C8 

 Fazer associação entre atributos (ver figura) 
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5. CRIAR UMA RELAÇÃO  

(entre a classe “sala_generica” e a tabela “docentes”) 

 

 New Relationship Class 

Name : Sala_docentes 

Origin Classe: Sala 

Taget Table :  docentes 

A cardinalidade tem de ser 1:1 para se poder efectuar a relação JOIN to ArcAMp 

Relação : “numero” == “numero_gabinete” 

 

 
 

 Ver no Arcmap 

Layers > Sala > Open Attribute Table 

Options > Related Tables 

Podemos adicionar um campo e inserir salas 

 

Relações - Regras 

 

É possível criar relações entre Classes espaciais e tabelas alfanuméricas e também entre tabelas. 

Os campos a relacionar têm de ser do mesmo tipo. 

 

Relações M-N 

Para efetuar Queries no ArcGis online é necessário que as relações entre classes/tabelas estejam 

implementadas. Ou seja, as classes associativas têm de ser transformadas em “relationship 

classes” do tipo M:N 

As relações M-N têm de ser implementadas com uma “Table Association”. As tabelas 

associativas devem ser preenchidas e testadas e só após a validação das relações podem ser 

convertidas para “relationship” no ArcGis. 

(http://desktop.arcgis.com/en/arcmap/10.3/manage-data/relationships/populating-an-

attributed-relationship-class-table-.htm You cannot populate an intermediate relationship class 

table between two tables in ArcMap; the Table To Relationship Class tool is the only method 

that can be used.) 

 

http://desktop.arcgis.com/en/arcmap/10.3/manage-data/relationships/populating-an-attributed-relationship-class-table-.htm
http://desktop.arcgis.com/en/arcmap/10.3/manage-data/relationships/populating-an-attributed-relationship-class-table-.htm
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As relationship classes podem ser criadas à mão no arccatalog ou podem ser criadas no 

arctollbox se já existir a tabela associativa. Nesse caso, para converter tabelas associativas em 

“relationship classes” :  

Data management > Relationship classes > Table to relationship class  

 

Exemplo de Relação M-N: Disciplina / sala_aula 

Entidades: Disciplina (c_disciplina), sala_aula (numero) 

Tabela associativa: disciplina_sala_aula_tabela 

C_disciplina numero 

SLG 8.1.64 

SLG 1.1.11 

PDI 1.1.12 

PDI 8.1.56 

 

Data management > Relationship classes > Table to relationship class  

Origin table: disciplina 

Destination table: sala_generica 

Output relationship : disciplina_sala_generica 

Relationship_table : disciplina_salaGenerica 

Cardinality: Many_to_many 

Attribute_fields: disciplina, numero_sala 

Origin primary key: nome_disciplina 

Origin foreign key: disciplina (igual ao atributo da tabela associativa) 

Destination primary key: numero_sala 

Destination foreign key: numero_sala (igual ao atributo da tabela associativa) 

 

 Verificar cascata com a função “identify” do arcmap (alterar o campo “display” em 

todas as tabelas e entidade geográficas para apresentar o que pretendemos) 

 Para verificar se a relação foi estabelecida: 

Select * from sala_aula where  

numero_sala IN (select numero_sala from disciplina_sala_generica where "disciplina" 

LIKE 'SLG') 
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6 CRIAR JOIN OU RELATES 

 

A criação de relações não permite a realização de interrogações à tabela alfanumérica a partir 

dos elementos gráficos. Para isso deveremos criar uma relação “JOIN” na qual se juntam os 

atributos das duas tabelas. 

 

Sobre a entidade geográfica “sala” realizar o JOIN. Existe a possibilidade de realizar um join 

baseado na relação já criada (“ .. on a predefined relashionship class”) 

 

 
 

 

Experimentar com “Keep all records” ou “keep only matching records” e ver o resultado. 

 

Fazer interrogações: 

Selection > Select by attributes > Qual é o gabinete da Profª ..? 
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7. Redes 

7. 1Criar uma Rede 
 

a) Criar uma entidade “CaminhoPedonal” (lineFeature, Coordinate include M, Z) 

Atributos (F_ELEV (Integer), T_ELEV (Integer), Nome (text)) (Elevação no inicio e fim do 

segmento) 

b) Desenhar as linhas e preencher os atributos 

 

c) Criar topologia > New > Topology > caminhoPedonal_topology 

> seleccionar “caminhoPedonal” 

> Add Rule > “must not intersect”; “must not self intersect”; “must not have pseudo 

nodes”; “must not have dangles” 

(acrescentar várias regras) 

 

d) Validar Topologia 

Editor > More Editing Tools > topology 

As interseções entre linhas tem de ocorrer nos “end points” 

 

4. Network dataset 

(http://desktop.arcgis.com/en/arcmap/latest/extensions/network-analyst/about-the-

network-analyst-tutorial-exercises.htm) 

 

a) Rede_viaria > New > Network Dataset > “caminhoPedonal_ND” 

 

> Do you want to model turns? Yes 

> Connectivity > endpoint (or any vertex) 

> Using elevation fields : ok (F_ELEV, T_ELEV) 

(Na união dos segmentos os valores de F_ELEV ou T_ELEV devem ser iguais) 

> Attributes > Length; usage: Cost 

> Travel Mode > pedonal 

 Type : walk 

 Impedance : lenght 

> Directions Settings> Length Units (meters)  

> Street Name Fields > Primary, NOME 

 

b) Verificar o funcionamento 

> Adicionar “caminhoPedonal_ND” e “caminhoPedonal_junctions” 

> Adicionar “toolbars > network analyst” 

> New Route > marcar dois pontos de inicio e fim do percurso 

> Fazer “solve” 

 

http://desktop.arcgis.com/en/arcmap/latest/extensions/network-analyst/about-the-network-analyst-tutorial-exercises.htm
http://desktop.arcgis.com/en/arcmap/latest/extensions/network-analyst/about-the-network-analyst-tutorial-exercises.htm
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7.2 Publicar um serviço network 
ArcGis Server da FCUL 

 

https://arcgis.fc.ul.pt/server/manager/  

User: SLG2019 

Pwd: SLG_2019 

ArcGis Server > Services > root  : Disponibilizar ao publico 

 

 

Ver manual: 
http://server.arcgis.com/en/server/latest/get-started/windows/tutorial-publishing-a-network-analysis-service.htm 

 

1. Criar o serviço no ArcMAp 

a) Network Analyst > new route 

b) remover todos os layers excepto o layer “route” . A página fica em branco 

c) File > share as > service 

d) Publish a service 

e) create a new one  > publish GIS services > server type > ArcGis Server 

f) service name > slg2016_ND 

g) use existing folder > “route” 

h) Capabilities > ativar “Network analysis” 

Tomar nota do endereço REST URL 

i) Analyse (não pode haver erros) 

j) Publish 

 

2. Verificar o serviço no Arcgis Server 

Entrar no arcgis server 

https://arcgis.fc.ul.pt/server/manager/  

 

a) entrar na pasta “route” 

b) entrar no serviço slg2016_ND 

c) Capabilities > Network dataset> copiar endereço REST URL 
 

http://arcgis.fc.ul.pt:6080/arcgis/rest/services/route/slg2016_ND/NAServer 

d) entrar neste serviço via browser e tomar nota do nome do “route layers” (route) 

Este nome deve ser adicionado ao endereço URL anterior 

 

 

 

 

https://arcgis.fc.ul.pt/server/manager/
http://server.arcgis.com/en/server/latest/get-started/windows/tutorial-publishing-a-network-analysis-service.htm
https://arcgis.fc.ul.pt/server/manager/
http://arcgis.fc.ul.pt:6080/arcgis/rest/services/route/slg2016_ND/NAServer
http://arcgis.fc.ul.pt:6080/arcgis/rest/services/route/slg2016_ND/NAServer
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7.3 Usar como serviço web 

 
1. Usar como serviço web no ArcMAp 

a) Abrir arcmap, com edifícios e caminhos (sem network dataset) 

b) No arccatalog > GIS Services > add ArcGIS Server (fazer login) 

c) adicionar o serviço “slg2016_ND” 

d) Comando “find route” (do lado direito dos binóculos) 

e) Nas opções fazer > Routing Service > “route” 

f) Add Stop (adicionar dois pontos para definir o caminho) 

g) Find route 
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8. Geocoding 

8.1 Create Address Locator 

http://desktop.arcgis.com/en/arcmap/10.3/guide-books/geocoding/creating-an-address-

locator.htm 

No arccatalog  

Na file folder> New > Address locator (na pasta da geodatabase) 

 

style: General - Single Field 

Reference data: sala_generica  

Keyfield: numero da sala (tem de ser do tipo texto) 

Additional Field : Edificio ou Piso 

Criar tantos quantos os necessários (um por cada entidade espacial: caminhos, salas, 

edifícios) 

Na file folder> New > Composite Address locator (na pasta da geodatabase) 

Juntar todos os address locators anteriores 

 

 

 

 

http://desktop.arcgis.com/en/arcmap/10.3/guide-books/geocoding/creating-an-address-locator.htm
http://desktop.arcgis.com/en/arcmap/10.3/guide-books/geocoding/creating-an-address-locator.htm
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8.2 Testar o geocoding 

Find Route > Options > Choose address locator > sala_generica_adress 

Stos > add stop > key : 8.1.47 (add as stop) 

Seleccionar outro ponto manualmente e executar : “Find Route” 

 

 

8.3 Publicar um serviço de geocoding (Publishing a geocode service) 

http://desktop.arcgis.com/en/arcmap/10.3/guide-books/geocoding/publishing-a-geocode-

service.htm 

1. No arcCatalog sobre o geodcode_adress, botão direito > Share as > geocode Service 

2. Service name > sala_generica_adress 

3. Capabilities: copiar o endereço REST URL 

http://arcgis.fc.ul.pt/arcgis/rest/services/route/sala_generica_adress/GeocodeServer 

4. Analyse + Publishing 

Entrar no ArcGis Server para verificar o funcionamento do serviço e copiar o URL 

http://arcgis.fc.ul.pt/arcgis/rest/services/route/sala_generica_adress/GeocodeServer 

 

8.4 Usar como serviço Web no ArcMap 

 

> No arccatalog > GIS Services > add ArcGIS Server (fazer login) 
> Adicionar o serviço “sala_generica_adress” 
> Find Route > Options > Choose address locator > sala_generica_adress 
> Add Stop (adicionar nome de sala para definir o caminho) 
> Find route 

 

  

http://desktop.arcgis.com/en/arcmap/10.3/guide-books/geocoding/publishing-a-geocode-service.htm
http://desktop.arcgis.com/en/arcmap/10.3/guide-books/geocoding/publishing-a-geocode-service.htm
http://arcgis.fc.ul.pt/arcgis/rest/services/route/sala_generica_adress/GeocodeServer
http://arcgis.fc.ul.pt/arcgis/rest/services/route/sala_generica_adress/GeocodeServer
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9. ARCGIS ONLINE / PORTAL 
 

PORTAL: conta SLG 
 
Utilizador: SLG_2019 
Senha: @rcGIS_2019 
 

Conta ArcGis online  
User: SLG2019 
Pwd: Slg_2019 

 

 
 

1. ArcMap 

Portal: (https://smart.campus.ciencias.ulisboa.pt/portal/home) 

ArcGis Online: https://www.arcgis.com/index.html (sign in) 

 

File > Sign In > ArcGis Online > Iniciar sessão em SMARTCAMPUS 

ArcGis : SLG_2019/@rcGIS_2019 

File > Share as > service > Publish a service >  

(na segunda vez que quiser publicar o serviço deverá escolher “overwrite an existing service”) 

 Choose a conection: 

“My Hosted Services (SMARTCAMPUS)” 

   > service name > NomedoGrupo (NG) 

Se for em ArcGis online  

“My Hosted Services (Universidade de Lisboa)” 

   > service name > NomedoGrupo (NG) 

 

    

Service Editor 

> Capabilities > Feature Access (desativar Tiled Mapping) 

  > Feature Access : Create, delete, Query, Sync, Update 

> Item Description > preencher todos os campos 

> Sharing> Everyone (public) 

 

> Analyse > se sem erros > Publish 

(Erros frequentes: https://support.esri.com/en/technical-article/000014995) 

 

2. ArcGIS Portal 

 

> Sign In 

 

a) > My content > Seleccionar o NG Feature Layer 

 

Podemos ver as propriedades. Verificar “Partilhar” e alterar para “Todos” 

Podemos ver as propriedades. Confirmar os layers importados. 

 

 

https://smart.campus.ciencias.ulisboa.pt/portal/home
https://www.arcgis.com/index.html
https://support.esri.com/en/technical-article/000014995
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b) Abrir no Visualizador de mapa  

> Adicionar a novo mapa com controlo total de edição > Guardar mapa 

 

c) > Editar os layers > Simbolo, transparencia, rename, etc.. 

 

> Selecionar a opção “Alterar o estilo” do menu de contexto de cada entidade geográfica 

Na opção 1: escolha um atributo para exibir (por exemplo Nome do Edifício) ou exibir apenas 

localização.  

Na opção 2: escolha o estilo do desenho : símbolo em função dos atributos ou único símbolo. 

(pode pesquisar na web por símbolos, ex. “tree icon png) 

Se o atributo for numérico pode definir símbolos de diferentes tamanhos, p.e. tamanho do 

símbolo árvore em função da sua altura ou diâmetro.  

 

. Repita esta operação para todos os elementos 

   

d) Filtrar elementos em função dos atributos 

 

e) Set visibility range 

 

e1) Guardar Mapa 

 

f) Partilhar >  (guardar o link) 

 

 > Criar uma aplicação Web >  

 > Explorar as aplicações configuráveis 

> Web AppBuilder > Iniciar 

> Escolher “Caixa de joias” ou “tema dobrável” 

> Pré-visualização > escolher o tablet ou telemóvel 

> No separador “Map” centrar o desenho na FCUL e escolher “Utilizar extensão atual do 

mapa” 

> Fazer “Guardar” 

 

 > Widgets > Temos disponíveis 5 widgets 

> Widget 1 > Temos disponíveis 47 operações 

> Analysis > Create Buffers 

> Edit (importante) 

 

> “Pesquisar” 

  > Adicionar origem de pesquisa > Camada de elementos > Sala  

 > “Consulta” 

> Nova consulta > sala  

> Filtros > Critérios de consulta …  

> adicionar expressão > Solicitar valores 

  > Nova consulta > docents 

   > adicionar expressão > “Nome docente “ é “unico” 
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   > solicitar valores > “todos os valores filtrados pro expressões 

anteriores” 

 

 > adicionar outros widgets (tipo basemap) 

  

> Directions 

 Route URL : inserir o endereço URL do serviço network e acrescentar o nome do layer)  

(http://arcgis.fc.ul.pt:6080/arcgis/rest/services/route/slg2016_ND/NAServer/route) 

 OK 

Geocode URL: inserir o URL do serviço geocoding 

http://arcgis.fc.ul.pt:6080/arcgis/rest/services/sala_generica_CreateAddressL/GeocodeServer 

 

 > Previews (veja como fica no seu telemóvel) 

 > Attributes > dar um nome ao mapa 

 

> SAVE 

 

https://smart.campus.ciencias.ulisboa.pt/portal/apps/webappviewer/index.html?id=eeb83e16

54e74cfd9ba77fd54f8e8f23 

 

  

http://arcgis.fc.ul.pt:6080/arcgis/rest/services/sala_generica_CreateAddressL/GeocodeServer
https://smart.campus.ciencias.ulisboa.pt/portal/apps/webappviewer/index.html?id=eeb83e1654e74cfd9ba77fd54f8e8f23
https://smart.campus.ciencias.ulisboa.pt/portal/apps/webappviewer/index.html?id=eeb83e1654e74cfd9ba77fd54f8e8f23
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10. ARCGIS Collector 
 

Página principal do utilizador SLG2019 

 

My content > aceda à sua feature layer e visualize os detalhes do item. 

 

Layers > escolha “edifício” e faça “enable attachments” que vai permitir adicionar imagens ao 

layer edifícios. 

 

 

No dispositivo móvel 

 

Iniciar sessão (http://www.arcgis.com, user: SLG2016_fculdegge, pwd: slg_2016) 

 

Selecione > todos os mapas > clique na miniatura para abrir 

 

Podemos mudar o mapa base (canto superior direito) 

 

> Pressionar um dos edifícios > editar o elemento 

 

> adicionar anexo (@+) : usar máquina fotográfica para fotografar edifício. 

 

> atualizar atributos das árvores 

 

> recolha novo elemento: por exemplo uma árvore ou um canteiro. 

  

http://www.arcgis.com/

